summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorTomas Chvatal <tchvatal@suse.cz>2012-04-25 12:42:26 +0200
committerTomas Chvatal <tchvatal@suse.cz>2012-04-25 12:42:26 +0200
commit1887295b120f685e04b67b993864c2fc6719bc00 (patch)
tree8452f00a14d5a07104a09d6b35217b6abae2632b /configure.ac
parent42e19643d20679eecc5feef7656065b95403b65b (diff)
downloadcppunit-1887295b120f685e04b67b993864c2fc6719bc00.tar.gz
Remove leftover from visio msvc compat.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac33
1 files changed, 4 insertions, 29 deletions
diff --git a/configure.ac b/configure.ac
index a5b0fd4..9352aff 100644
--- a/configure.ac
+++ b/configure.ac
@@ -95,36 +95,11 @@ AS_IF([test x"$enable_werror" != "xno"], [
CFLAGS="$CFLAGS -Werror"
CXXFLAGS="$CXXFLAGS -Werror"
])
-# Courtesy of Glib: Ensure MSVC-compatible struct packing convention
-# is used when compiling for Win32 with gcc.
-AS_IF([test "x$native_win32" = "xyes"], [
- AC_CHECK_TOOL(WINDRES, windres)
- AS_IF([test x"$GCC" = xyes], [
- AC_MSG_CHECKING([how to get MSVC-compatible struct packing])
- AS_IF([test -z "$ac_cv_prog_CC"], [
- our_gcc="$CC"
- ], [
- our_gcc="$ac_cv_prog_CC"
- ])
- AS_IF([$our_gcc -v --help 2>/dev/null | grep ms-bitfields >/dev/null], [
- msnative_struct="-mms-bitfields"
- CFLAGS="$CFLAGS $msnative_struct"
- CXXFLAGS="$CXXFLAGS $msnative_struct"
- AC_MSG_RESULT([${msnative_struct}])
- ], [
- AC_MSG_RESULT([no way])
- AC_MSG_WARN([produced libraries might be incompatible with MSVC-compiled code])
- ])
- ])
+AS_IF([test x"$GCC" = xyes], [
+ # Be tough with warnings and produce less careless code
+ # Weffc++ currently prints too much warnings
CFLAGS="$CFLAGS -Wall -pedantic"
- CXXFLAGS="$CXXFLAGS -Wall -pedantic"
-], [
- AS_IF([test x"$GCC" = xyes], [
- # Be tough with warnings and produce less careless code
- # Weffc++ currently prints too much warnings
- CFLAGS="$CFLAGS -Wall -pedantic"
- CXXFLAGS="$CXXFLAGS -Wall -pedantic" # -Weffc++"
- ])
+ CXXFLAGS="$CXXFLAGS -Wall -pedantic" # -Weffc++"
])
CPPUNIT_CXXFLAGS="$CPPUNIT_CFLAGS"
AC_SUBST(CPPUNIT_CXXFLAGS)