summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2016-09-07 11:06:17 -0700
committerBenjamin Peterson <benjamin@python.org>2016-09-07 11:06:17 -0700
commit06c2472156a7ab7650b0683f656b2a71193f2952 (patch)
tree09edc1069c164c05b5df2846a5a31a4652e17a61 /configure.ac
parent3af3e2aa8be1707ca28c6b2ccbaf801c944e39ec (diff)
downloadcpython-06c2472156a7ab7650b0683f656b2a71193f2952.tar.gz
require C99 bool
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 0 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index b511a79ba4..d89ebef608 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2128,17 +2128,7 @@ if test "$have_long_double" = yes ; then
AC_CHECK_SIZEOF(long double, 16)
fi
-
-AC_MSG_CHECKING(for _Bool support)
-have_c99_bool=no
-AC_COMPILE_IFELSE([AC_LANG_PROGRAM([[]], [[_Bool x; x = (_Bool)0;]])],[
- AC_DEFINE(HAVE_C99_BOOL, 1, [Define this if you have the type _Bool.])
- have_c99_bool=yes
-],[])
-AC_MSG_RESULT($have_c99_bool)
-if test "$have_c99_bool" = yes ; then
AC_CHECK_SIZEOF(_Bool, 1)
-fi
AC_CHECK_SIZEOF(off_t, [], [
#ifdef HAVE_SYS_TYPES_H