summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-21 12:48:26 +0100
committerXavier de Gaye <xdegaye@users.sourceforge.net>2016-12-21 12:48:26 +0100
commit164324b35f8ec656cb0c883d00a430ef67bfaee4 (patch)
tree3b69a3299366fd2deb62edee68a4b812766cb580 /configure.ac
parentfa2e23427743f2738a8fdac44b235dd26f61286b (diff)
parent0600f750ef142dc1594bc489d17a43453a74ea80 (diff)
downloadcpython-164324b35f8ec656cb0c883d00a430ef67bfaee4.tar.gz
Issue #28538: Merge 3.6.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 24 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 61fad0098c..cb43b28b76 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ dnl * Please run autoreconf to test your changes! *
dnl ***********************************************
# Set VERSION so we only need to edit in one place (i.e., here)
-m4_define(PYTHON_VERSION, 3.6)
+m4_define(PYTHON_VERSION, 3.7)
AC_PREREQ(2.65)
@@ -2773,23 +2773,27 @@ AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]),,,)
-case "$with_system_ffi" in
- "")
- case $ac_sys_system in
- Darwin)
- with_system_ffi="no"
- ;;
- *)
- with_system_ffi="yes"
- ;;
- esac
- ;;
- yes|no)
- ;;
- *)
- AC_MSG_ERROR([--with-system-ffi accepts no arguments])
- ;;
-esac
+if test "$ac_sys_system" = "Darwin"
+then
+ case "$with_system_ffi" in
+ "")
+ with_system_ffi="no"
+ ;;
+ yes|no)
+ ;;
+ *)
+ AC_MSG_ERROR([--with-system-ffi accepts no arguments])
+ ;;
+ esac
+ AC_MSG_RESULT($with_system_ffi)
+else
+ AC_MSG_RESULT(yes)
+ if test "$with_system_ffi" != ""
+ then
+ AC_MSG_WARN([--with(out)-system-ffi is ignored on this platform])
+ fi
+ with_system_ffi="yes"
+fi
if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
@@ -2798,8 +2802,6 @@ else
fi
AC_SUBST(LIBFFI_INCLUDEDIR)
-AC_MSG_RESULT($with_system_ffi)
-
# Check for use of the system libmpdec library
AC_MSG_CHECKING(for --with-system-libmpdec)
AC_ARG_WITH(system_libmpdec,
@@ -3895,6 +3897,8 @@ AC_CHECK_MEMBERS([struct passwd.pw_gecos, struct passwd.pw_passwd], [], [], [[
#include <sys/types.h>
#include <pwd.h>
]])
+# Issue #21085: In Cygwin, siginfo_t does not have si_band field.
+AC_CHECK_MEMBERS([siginfo_t.si_band], [], [], [[#include <signal.h>]])
AC_MSG_CHECKING(for time.h that defines altzone)
AC_CACHE_VAL(ac_cv_header_time_altzone,[