summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authordoko <doko@ubuntu.com>2012-06-30 18:25:32 +0200
committerdoko <doko@ubuntu.com>2012-06-30 18:25:32 +0200
commit92e122f33b165d03ac4db697868027981c13ec03 (patch)
treefa71a0469201bed8611f5160a74131a5d253fbea /configure.ac
parent755948d31e4e10ce3e593d450e784ba0e42ea9a9 (diff)
downloadcpython-92e122f33b165d03ac4db697868027981c13ec03.tar.gz
- Issue #3754: Use readelf instead of ldd for the cross build readline check
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eb0763afcf..00ed902d54 100644
--- a/configure.ac
+++ b/configure.ac
@@ -926,6 +926,16 @@ then
ARFLAGS="rc"
fi
+AC_CHECK_TOOLS([READELF], [readelf], [:])
+if test "$cross_compiling" = yes; then
+ case "$READELF" in
+ readelf|:)
+ AC_MSG_ERROR([readelf for the host is required for cross builds])
+ ;;
+ esac
+fi
+AC_SUBST(READELF)
+
AC_SUBST(DISABLE_ASDLGEN)
DISABLE_ASDLGEN=""
AC_CHECK_PROG(HAS_PYTHON, python, found, not-found)