summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMartin Panter <vadmium+py@gmail.com>2016-09-12 01:32:03 +0000
committerMartin Panter <vadmium+py@gmail.com>2016-09-12 01:32:03 +0000
commitbc439c05c3709839a022afc1dbc474d5b6a30c15 (patch)
tree590ca802802129856373d3fef0c5768f263abe02 /configure.ac
parenta3c945c69eab57cf8fac23a67078c01de4543ea7 (diff)
downloadcpython-bc439c05c3709839a022afc1dbc474d5b6a30c15.tar.gz
Issue #28066: Fix include search directory logic for out-of-tree builds
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 36758d46dd..381bab0523 100644
--- a/configure.ac
+++ b/configure.ac
@@ -10,7 +10,7 @@ AC_PREREQ(2.65)
AC_INIT(python, PYTHON_VERSION, https://bugs.python.org/)
AC_SUBST(BASECPPFLAGS)
-if test "$abs_srcdir" != "$abs_builddir"; then
+if test "$srcdir" != . -a "$srcdir" != "$(pwd)"; then
# If we're building out-of-tree, we need to make sure the following
# resources get picked up before their $srcdir counterparts.
# Objects/ -> typeslots.inc