summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGregory P. Smith <greg@krypto.org>2016-11-20 21:07:42 +0000
committerGregory P. Smith <greg@krypto.org>2016-11-20 21:07:42 +0000
commitc2832346c5366b2fa81f7552a067cb51bd9711f1 (patch)
treed08210c50fe03528d88e6039c93b5769514f56e8 /configure.ac
parente7c5f1819e453aaacc8ea5665946c5de5ca51fd3 (diff)
downloadcpython-c2832346c5366b2fa81f7552a067cb51bd9711f1.tar.gz
Rename the new --with-optimiations flag to --enable-optimizations.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 381bab0523..4e55871772 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1234,8 +1234,8 @@ fi],
AC_SUBST(DEF_MAKE_ALL_RULE)
AC_SUBST(DEF_MAKE_RULE)
Py_OPT='false'
-AC_MSG_CHECKING(for --with-optimizations)
-AC_ARG_WITH(optimizations, AS_HELP_STRING([--with-optimizations], [Enable expensive optimizations (PGO, maybe LTO, etc). Disabled by default.]),
+AC_MSG_CHECKING(for --enable-optimizations)
+AC_ARG_ENABLE(optimizations, AS_HELP_STRING([--enable-optimizations], [Enable expensive optimizations (PGO, maybe LTO, etc). Disabled by default.]),
[
if test "$withval" != no
then
@@ -1351,7 +1351,7 @@ case $CC in
LLVM_PROF_ERR=yes
if test "${REQUIRE_PGO}" = "yes"
then
- AC_MSG_ERROR([llvm-profdata is required for a --with-optimizations build but could not be found.])
+ AC_MSG_ERROR([llvm-profdata is required for a --enable-optimizations build but could not be found.])
fi
fi
;;
@@ -1367,7 +1367,7 @@ case $CC in
LLVM_PROF_ERR=yes
if test "${REQUIRE_PGO}" = "yes"
then
- AC_MSG_ERROR([llvm-profdata is required for a --with-optimizations build but could not be found.])
+ AC_MSG_ERROR([llvm-profdata is required for a --enable-optimizations build but could not be found.])
fi
fi
;;
@@ -5379,7 +5379,7 @@ if test "$Py_OPT" = 'false' -a "$Py_DEBUG" != 'true'; then
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
echo "If you want a release build with all optimizations active (LTO, PGO, etc),"
- echo "please run ./configure --with-optimizations" >&AS_MESSAGE_FD
+ echo "please run ./configure --enable-optimizations" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
echo "" >&AS_MESSAGE_FD
fi