summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorYury Selivanov <yury@magic.io>2016-11-03 15:36:02 -0700
committerYury Selivanov <yury@magic.io>2016-11-03 15:36:02 -0700
commitebd703ca95354d2b4ef8ea831973e88cbf2c4c8c (patch)
treec04d19c84f7aae1b2fb66e96ee0bb2e23c0b80cd /configure.ac
parente9bb4f5884252f4aaced7b198f8286900e952201 (diff)
parentf7587e580718e47abcbe5c3d68ca84205ea3c9c2 (diff)
downloadcpython-ebd703ca95354d2b4ef8ea831973e88cbf2c4c8c.tar.gz
Merge 3.6 (asyncio)
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac44
1 files changed, 24 insertions, 20 deletions
diff --git a/configure.ac b/configure.ac
index 8ce2ae998e..1ca8825f19 100644
--- a/configure.ac
+++ b/configure.ac
@@ -3,7 +3,7 @@ dnl * Please run autoreconf to test your changes! *
dnl ***********************************************
# Set VERSION so we only need to edit in one place (i.e., here)
-m4_define(PYTHON_VERSION, 3.6)
+m4_define(PYTHON_VERSION, 3.7)
AC_PREREQ(2.65)
@@ -2795,23 +2795,27 @@ AC_MSG_CHECKING(for --with-system-ffi)
AC_ARG_WITH(system_ffi,
AS_HELP_STRING([--with-system-ffi], [build _ctypes module using an installed ffi library]),,,)
-case "$with_system_ffi" in
- "")
- case $ac_sys_system in
- Darwin)
- with_system_ffi="no"
- ;;
- *)
- with_system_ffi="yes"
- ;;
- esac
- ;;
- yes|no)
- ;;
- *)
- AC_MSG_ERROR([--with-system-ffi accepts no arguments])
- ;;
-esac
+if test "$ac_sys_system" = "Darwin"
+then
+ case "$with_system_ffi" in
+ "")
+ with_system_ffi="no"
+ ;;
+ yes|no)
+ ;;
+ *)
+ AC_MSG_ERROR([--with-system-ffi accepts no arguments])
+ ;;
+ esac
+ AC_MSG_RESULT($with_system_ffi)
+else
+ AC_MSG_RESULT(yes)
+ if test "$with_system_ffi" != ""
+ then
+ AC_MSG_WARN([--with(out)-system-ffi is ignored on this platform])
+ fi
+ with_system_ffi="yes"
+fi
if test "$with_system_ffi" = "yes" && test -n "$PKG_CONFIG"; then
LIBFFI_INCLUDEDIR="`"$PKG_CONFIG" libffi --cflags-only-I 2>/dev/null | sed -e 's/^-I//;s/ *$//'`"
@@ -2820,8 +2824,6 @@ else
fi
AC_SUBST(LIBFFI_INCLUDEDIR)
-AC_MSG_RESULT($with_system_ffi)
-
# Check for use of the system libmpdec library
AC_MSG_CHECKING(for --with-system-libmpdec)
AC_ARG_WITH(system_libmpdec,
@@ -3905,6 +3907,8 @@ AC_CHECK_MEMBERS([struct passwd.pw_gecos, struct passwd.pw_passwd], [], [], [[
#include <sys/types.h>
#include <pwd.h>
]])
+# Issue #21085: In Cygwin, siginfo_t does not have si_band field.
+AC_CHECK_MEMBERS([siginfo_t.si_band], [], [], [[#include <signal.h>]])
AC_MSG_CHECKING(for time.h that defines altzone)
AC_CACHE_VAL(ac_cv_header_time_altzone,[