summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorJack Jansen <jack.jansen@cwi.nl>2004-07-16 08:43:47 +0000
committerJack Jansen <jack.jansen@cwi.nl>2004-07-16 08:43:47 +0000
commitd1f1b932c8a77fb1d17b00f058ee33c730d66aa1 (patch)
tree2dc2353198a0cec06b485d13954108f238a76247 /configure.in
parent99e6872543e8a729831882578aba0bb118a5e166 (diff)
downloadcpython-d1f1b932c8a77fb1d17b00f058ee33c730d66aa1.tar.gz
Don't hardcode "Python" as the framework name, we have a variable for it:
$PYTHONFRAMEWORK.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5503a17207..77522c35f6 100644
--- a/configure.in
+++ b/configure.in
@@ -1180,12 +1180,12 @@ case $ac_sys_system/$ac_sys_release in
Darwin/1.3*)
LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc"
LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
- LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/Python'
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
Darwin/*)
LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc"
LIBTOOL_CRUFT="$LIBTOOL_CRUFT $extra_frameworks"
- LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/Python'
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
esac
@@ -1399,7 +1399,7 @@ then
LINKFORSHARED="$extra_undefs -framework System"
if test "$enable_framework"
then
- LINKFORSHARED="$LINKFORSHARED -Wl,-F. -framework Python"
+ LINKFORSHARED="$LINKFORSHARED -Wl,-F. -framework "'$(PYTHONFRAMEWORK)'
fi
LINKFORSHARED="$LINKFORSHARED $extra_frameworks";;
OpenUNIX*|UnixWare*) LINKFORSHARED="-Wl,-Bexport";;