summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorBob Ippolito <bob@redivi.com>2005-03-28 23:23:47 +0000
committerBob Ippolito <bob@redivi.com>2005-03-28 23:23:47 +0000
commitedcfb299b5b947b94d29cb52d23425b34591ef74 (patch)
treef4beed6cab078909d0fc084272851f237d0c0a09 /configure.in
parent8d3c180f3b52ed17fe94d51930eb47452fe67964 (diff)
downloadcpython-edcfb299b5b947b94d29cb52d23425b34591ef74.tar.gz
patch [1171735] - Darwin 8's headers disable functionality when
POSIX is enabled. This prevents the toolbox glue, all of Carbon, and various other non-POSIX features from compiling. The POSIX symbols are still used by default, so turning off the #define doesn't hurt. Additionally, linker flags have changed for Darwin 8, and are different for Darwin 8/gcc4 (default) and Darwin 8/gcc3.3. Approved by Anthony
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in33
1 files changed, 28 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 13b8439dd2..6f292f93f6 100644
--- a/configure.in
+++ b/configure.in
@@ -171,6 +171,12 @@ case $ac_sys_system/$ac_sys_release in
define_xopen_source=no
fi
;;
+ # On Mac OS X 10.4, defining _POSIX_C_SOURCE or _XOPEN_SOURCE
+ # disables platform specific features beyond repair.
+ Darwin/8.*)
+ define_xopen_source=no
+ ;;
+
esac
if test $define_xopen_source = yes
@@ -194,8 +200,9 @@ then
# cases for HP-UX, we define it globally.
AC_DEFINE(_XOPEN_SOURCE_EXTENDED, 1, Define to activate Unix95-and-earlier features)
- AC_DEFINE(_POSIX_C_SOURCE, 200112L, Define to activate features from IEEE Stds 1003.1-2001)
+ AC_DEFINE(_POSIX_C_SOURCE, 200112L, Define to activate features from IEEE Stds 1003.1-2001)
+
fi
#
@@ -1205,15 +1212,31 @@ yes)
esac
AC_MSG_RESULT($enable_toolbox_glue)
+AC_SUBST(OTHER_LIBTOOL_OPT)
+case $ac_sys_system/$ac_sys_release in
+ Darwin/@<:@01234567@:>@.*)
+ OTHER_LIBTOOL_OPT="-prebind -seg1addr 0x10000000"
+ ;;
+ Darwin/*)
+ OTHER_LIBTOOL_OPT=""
+ ;;
+esac
+
AC_SUBST(LIBTOOL_CRUFT)
case $ac_sys_system/$ac_sys_release in
- Darwin/1.3*)
- LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc"
+ Darwin/@<:@01234567@:>@.*)
+ LIBTOOL_CRUFT="-framework System -lcc_dynamic -arch_only ppc"
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
Darwin/*)
- LIBTOOL_CRUFT="-lcc_dynamic -arch_only ppc"
- LIBTOOL_CRUFT="$LIBTOOL_CRUFT"
+ gcc_version=`gcc -v 2>&1 | grep version | cut -d\ -f3`
+ if test ${gcc_version} '<' 4.0
+ then
+ LIBTOOL_CRUFT="-lcc_dynamic"
+ else
+ LIBTOOL_CRUFT=""
+ fi
+ LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -lSystem -lSystemStubs -arch_only ppc'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -install_name $(PYTHONFRAMEWORKINSTALLDIR)/Versions/$(VERSION)/$(PYTHONFRAMEWORK)'
LIBTOOL_CRUFT=$LIBTOOL_CRUFT' -compatibility_version $(VERSION) -current_version $(VERSION)';;
esac