summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorGregory P. Smith <greg@mad-scientist.com>2007-09-09 06:44:34 +0000
committerGregory P. Smith <greg@mad-scientist.com>2007-09-09 06:44:34 +0000
commit0398864e839facfe71bec9f1e24d19202cc6b6d7 (patch)
treeb4803aaa837d1cabef1b187c9e12482441d7c024 /setup.py
parentaa702790176a8220071b27d0a5d1af7257515762 (diff)
downloadcpython-0398864e839facfe71bec9f1e24d19202cc6b6d7.tar.gz
Adds stand alone _md5 and _sha1 modules for use by hashlib on systems
when the OpenSSL library is either not present or not found by setup.py. These are derived from the public domain libtomcrypt (libtom.org) just like the existing sha256 and sha512 modules.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a0a02cbe3d..b2e1cac831 100644
--- a/setup.py
+++ b/setup.py
@@ -618,6 +618,11 @@ class PyBuildExt(build_ext):
exts.append( Extension('_sha256', ['sha256module.c']) )
exts.append( Extension('_sha512', ['sha512module.c']) )
+ if not openssl_ver:
+ # no openssl at all, use our own md5 and sha1
+ exts.append( Extension('_md5', ['md5module.c']) )
+ exts.append( Extension('_sha1', ['sha1module.c']) )
+
# Modules that provide persistent dictionary-like semantics. You will
# probably want to arrange for at least one of them to be available on
# your machine, though none are defined by default because of library