summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBrett Cannon <bcannon@gmail.com>2010-09-14 19:41:23 +0000
committerBrett Cannon <bcannon@gmail.com>2010-09-14 19:41:23 +0000
commit25728018e5d4614feedc868cbe717aac3fe4308a (patch)
treeca4d061354b328a1edfb6b0d79f4b8a433db8092 /setup.py
parent256ec9c80084cf5bfc079859607dcd97e2e80ee9 (diff)
downloadcpython-25728018e5d4614feedc868cbe717aac3fe4308a.tar.gz
setup.py was trying to build _weakref which is redundant as it's a built-in
module. Closes issue #9848. Thanks to Arfrever Frehtes Taifersar Arahesis for the bug report.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 0 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 85cd6057c9..861f9ef04d 100644
--- a/setup.py
+++ b/setup.py
@@ -456,9 +456,6 @@ class PyBuildExt(build_ext):
# on pretty much any POSIXish platform.
#
- # Some modules that are normally always on:
- exts.append( Extension('_weakref', ['_weakref.c']) )
-
# array objects
exts.append( Extension('array', ['arraymodule.c']) )
# complex math library functions