diff options
author | Anthony Baxter <anthonybaxter@gmail.com> | 2004-10-13 15:54:17 +0000 |
---|---|---|
committer | Anthony Baxter <anthonybaxter@gmail.com> | 2004-10-13 15:54:17 +0000 |
commit | 29515e3172d938a47da2fef774e3c2ad79223563 (patch) | |
tree | 36b5e1ac4c8812bb08dd89fb5fa378aabeaed8c0 /setup.py | |
parent | fdf4e5f132c319707cbc2ffa68294440e7a5021d (diff) | |
download | cpython-29515e3172d938a47da2fef774e3c2ad79223563.tar.gz |
Patch 983206: distutils obeys LDSHARED env var. Removed the code in
Python's own setup.py that did the same thing (and tested on Solaris,
where LDSHARED is needed...)
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 3 |
1 files changed, 0 insertions, 3 deletions
@@ -167,15 +167,12 @@ class PyBuildExt(build_ext): # those environment variables passed into the setup.py phase. Here's # a small set of useful ones. compiler = os.environ.get('CC') - linker_so = os.environ.get('LDSHARED') args = {} # unfortunately, distutils doesn't let us provide separate C and C++ # compilers if compiler is not None: (ccshared,opt,base) = sysconfig.get_config_vars('CCSHARED','OPT','BASECFLAGS') args['compiler_so'] = compiler + ' ' + opt + ' ' + ccshared + ' ' + base - if linker_so is not None: - args['linker_so'] = linker_so self.compiler.set_executables(**args) build_ext.build_extensions(self) |