summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorINADA Naoki <songofacandy@gmail.com>2016-10-09 14:44:47 +0900
committerINADA Naoki <songofacandy@gmail.com>2016-10-09 14:44:47 +0900
commit553d3108ffde8deed850a944a66a344c2fb14fd2 (patch)
tree7004221e4f371986d22de0fe63ad3a20c527447a /setup.py
parent38e4fe848672e8c3edc84e25b703f35d8924623d (diff)
downloadcpython-553d3108ffde8deed850a944a66a344c2fb14fd2.tar.gz
Issue #26801: Added C implementation of asyncio.Future.
Original patch by Yury Selivanov.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index a1989aa3cc..1d4a7f883a 100644
--- a/setup.py
+++ b/setup.py
@@ -656,6 +656,8 @@ class PyBuildExt(build_ext):
depends=['unicodedata_db.h', 'unicodename_db.h']) )
# _opcode module
exts.append( Extension('_opcode', ['_opcode.c']) )
+ # Fast asyncio Future implementation
+ exts.append( Extension("_futures", ["_futuresmodule.c"]) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be