diff options
author | Matthias Klose <doko@ubuntu.com> | 2010-04-21 22:21:03 +0000 |
---|---|---|
committer | Matthias Klose <doko@ubuntu.com> | 2010-04-21 22:21:03 +0000 |
commit | 5d884706782e758460f9fcc4c321872511f82c30 (patch) | |
tree | 06ad5a8a4e20ccca00cbd2001189657e1da902fb /setup.py | |
parent | f62ee988d16be89f401a4393260e69713fb5c4ae (diff) | |
download | cpython-5d884706782e758460f9fcc4c321872511f82c30.tar.gz |
Merged revisions 80322 via svnmerge from
svn+ssh://pythondev@svn.python.org/python/trunk
........
r80322 | matthias.klose | 2010-04-22 00:18:52 +0200 (Do, 22 Apr 2010) | 2 lines
- Build the ossaudio extension on GNU/kFreeBSD.
........
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 5 |
1 files changed, 3 insertions, 2 deletions
@@ -1227,8 +1227,9 @@ class PyBuildExt(build_ext): # End multiprocessing # Platform-specific libraries - if platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6', - 'freebsd7', 'freebsd8'): + if (platform in ('linux2', 'freebsd4', 'freebsd5', 'freebsd6', + 'freebsd7', 'freebsd8') + or platform.startswith("gnukfreebsd")): exts.append( Extension('ossaudiodev', ['ossaudiodev.c']) ) else: missing.append('ossaudiodev') |