summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorMartin v. Löwis <martin@v.loewis.de>2001-03-21 07:44:53 +0000
committerMartin v. Löwis <martin@v.loewis.de>2001-03-21 07:44:53 +0000
commit8f5132d2a622b3bf8f11867b34334df50bd6590f (patch)
tree87064a01167148f14ec93daa73395d530d17f567 /setup.py
parent0f07d619b243a16b0142eead4a32a0e5faf1040f (diff)
downloadcpython-8f5132d2a622b3bf8f11867b34334df50bd6590f.tar.gz
Remove Tix detection from Tkinter part; lib-tk/Tix attempts to load Tix
by requiring it. Also remove commentary from Setup.dist about commenting in and out stuff.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py16
1 files changed, 1 insertions, 15 deletions
diff --git a/setup.py b/setup.py
index 61c4fad102..d99f43dd7f 100644
--- a/setup.py
+++ b/setup.py
@@ -504,16 +504,7 @@ class PyBuildExt(build_ext):
def detect_tkinter(self, inc_dirs, lib_dirs):
# The _tkinter module.
- #
- # The command for _tkinter is long and site specific. Please
- # uncomment and/or edit those parts as indicated. If you don't have a
- # specific extension (e.g. Tix or BLT), leave the corresponding line
- # commented out. (Leave the trailing backslashes in! If you
- # experience strange errors, you may want to join all uncommented
- # lines and remove the backslashes -- the backslash interpretation is
- # done by the shell's "read" command and it may not be implemented on
- # every system.
-
+
# Assume we haven't found any of the libraries or include files
tcllib = tklib = tcl_includes = tk_includes = None
for version in ['8.4', '8.3', '8.2', '8.1', '8.0']:
@@ -562,11 +553,6 @@ class PyBuildExt(build_ext):
include_dirs.append('/usr/X11/include')
added_lib_dirs.append('/usr/X11/lib')
- # Check for Tix extension
- if self.compiler.find_library_file(lib_dirs + added_lib_dirs, 'tix4.1.8.0'):
- defs.append( ('WITH_TIX', 1) )
- libs.append('tix4.1.8.0')
-
# Check for BLT extension
if self.compiler.find_library_file(lib_dirs + added_lib_dirs, 'BLT8.0'):
defs.append( ('WITH_BLT', 1) )