summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNadeem Vawda <nadeem.vawda@gmail.com>2011-11-30 00:25:06 +0200
committerNadeem Vawda <nadeem.vawda@gmail.com>2011-11-30 00:25:06 +0200
commitac80eabcd5798eee45342f8e84d56a7e059f8e26 (patch)
treef06c58b42ab23a9668f0afac61df43de599f50cb /setup.py
parentadb9b0983c17e78cc90c332d19d7453252f4dbe7 (diff)
downloadcpython-ac80eabcd5798eee45342f8e84d56a7e059f8e26.tar.gz
Issue #6715: Add module for compression using the LZMA algorithm.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 7 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index fff43619ae..39aff67ab3 100644
--- a/setup.py
+++ b/setup.py
@@ -1279,6 +1279,13 @@ class PyBuildExt(build_ext):
else:
missing.append('_bz2')
+ # LZMA compression support.
+ if self.compiler.find_library_file(lib_dirs, 'lzma'):
+ exts.append( Extension('_lzma', ['_lzmamodule.c'],
+ libraries = ['lzma']) )
+ else:
+ missing.append('_lzma')
+
# Interface to the Expat XML parser
#
# Expat was written by James Clark and is now maintained by a group of