summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorBenjamin Peterson <benjamin@python.org>2009-05-23 16:34:23 +0000
committerBenjamin Peterson <benjamin@python.org>2009-05-23 16:34:23 +0000
commitebe8ab80c87e28575c0bc108827e1a4061ea8238 (patch)
tree0827af8ec1cc9d2a56acba2253c2000c85a013b5 /setup.py
parentbc2625a66ed0257c13e712f18cfcb7c70ccefe6e (diff)
downloadcpython-ebe8ab80c87e28575c0bc108827e1a4061ea8238.tar.gz
build _functools and _locale into the core library
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py18
1 files changed, 0 insertions, 18 deletions
diff --git a/setup.py b/setup.py
index ddd54526e5..f4adfd4dee 100644
--- a/setup.py
+++ b/setup.py
@@ -424,8 +424,6 @@ class PyBuildExt(build_ext):
exts.append( Extension("_heapq", ["_heapqmodule.c"]) )
# operator.add() and similar goodies
exts.append( Extension('operator', ['operator.c']) )
- # _functools
- exts.append( Extension("_functools", ["_functoolsmodule.c"]) )
# C-optimized pickle replacement
exts.append( Extension("_pickle", ["_pickle.c"]) )
# atexit
@@ -439,22 +437,6 @@ class PyBuildExt(build_ext):
exts.append( Extension('_lsprof', ['_lsprof.c', 'rotatingtree.c']) )
# static Unicode character database
exts.append( Extension('unicodedata', ['unicodedata.c']) )
- # access to ISO C locale support
- data = open('pyconfig.h').read()
- m = re.search(r"#s*define\s+WITH_LIBINTL\s+1\s*", data)
- if m is not None:
- locale_libs = ['intl']
- else:
- locale_libs = []
- if platform == 'darwin':
- locale_extra_link_args = ['-framework', 'CoreFoundation']
- else:
- locale_extra_link_args = []
-
-
- exts.append( Extension('_locale', ['_localemodule.c'],
- libraries=locale_libs,
- extra_link_args=locale_extra_link_args) )
# Modules with some UNIX dependencies -- on by default:
# (If you have a really backward UNIX, select and socket may not be