diff options
author | Trent Nelson <trent@trent.me> | 2012-10-16 08:13:12 -0400 |
---|---|---|
committer | Trent Nelson <trent@trent.me> | 2012-10-16 08:13:12 -0400 |
commit | f14a2473119e5b9b2c92b202e6404ca4e9dd4aa3 (patch) | |
tree | 9730cde1c7714c6909e82f63706f3e2527df8a96 /setup.py | |
parent | 408275433ff4d6e33d59a2181750f26d87934be7 (diff) | |
download | cpython-f14a2473119e5b9b2c92b202e6404ca4e9dd4aa3.tar.gz |
Issue #15298: ensure _sysconfigdata is generated in build directory,
not source directory.
Patch by Richard Oudkerk (sbt).
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 14 |
1 files changed, 0 insertions, 14 deletions
@@ -33,10 +33,6 @@ COMPILED_WITH_PYDEBUG = ('--with-pydebug' in sysconfig.get_config_var("CONFIG_AR # This global variable is used to hold the list of modules to be disabled. disabled_module_list = [] -# File which contains the directory for shared mods (for sys.path fixup -# when running from the build dir, see Modules/getpath.c) -_BUILDDIR_COOKIE = "pybuilddir.txt" - def add_dir_to_list(dirlist, dir): """Add the directory 'dir' to the list 'dirlist' (after any relative directories) if: @@ -252,16 +248,6 @@ class PyBuildExt(build_ext): args['compiler_so'] = compiler + ' ' + ccshared + ' ' + cflags self.compiler.set_executables(**args) - # Not only do we write the builddir cookie, but we manually install - # the shared modules directory if it isn't already in sys.path. - # Otherwise trying to import the extensions after building them - # will fail. - with open(_BUILDDIR_COOKIE, "wb") as f: - f.write(self.build_lib.encode('utf-8', 'surrogateescape')) - abs_build_lib = os.path.join(os.getcwd(), self.build_lib) - if abs_build_lib not in sys.path: - sys.path.append(abs_build_lib) - build_ext.build_extensions(self) longest = max([len(e.name) for e in self.extensions]) |