summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Krah <skrah@bytereef.org>2012-09-01 14:21:22 +0200
committerStefan Krah <skrah@bytereef.org>2012-09-01 14:21:22 +0200
commitf36f84003150846a1c4d42a3a7ae3fd5aa4af42e (patch)
tree6455c4ad91df90c979108c89f3bbadceef8c6500 /setup.py
parenta2d8402f182c1a2c25593e2f0991d0c28e497367 (diff)
downloadcpython-f36f84003150846a1c4d42a3a7ae3fd5aa4af42e.tar.gz
Compile _decimal without asserts and update benchmark results.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 7f863a4789..9ddf2e9add 100644
--- a/setup.py
+++ b/setup.py
@@ -1897,7 +1897,7 @@ class PyBuildExt(build_ext):
def _decimal_ext(self):
extra_compile_args = []
- undef_macros = ['NDEBUG']
+ undef_macros = []
if '--with-system-libmpdec' in sysconfig.get_config_var("CONFIG_ARGS"):
include_dirs = []
libraries = ['mpdec']