summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 0eca3ec361..8624bc9943 100644
--- a/setup.py
+++ b/setup.py
@@ -2006,6 +2006,11 @@ class PyBuildExt(build_ext):
if not sysconfig.get_config_var('WITH_THREAD'):
define_macros.append(('WITHOUT_THREADS', 1))
+ # Increase warning level for gcc:
+ if 'gcc' in cc:
+ extra_compile_args.extend(['-Wextra',
+ '-Wno-missing-field-initializers'])
+
# Uncomment for extra functionality:
#define_macros.append(('EXTRA_FUNCTIONALITY', 1))
ext = Extension (