summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authormsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2014-03-21 13:52:34 +0000
committermsweet <msweet@a1ca3aef-8c08-0410-bb20-df032aa958be>2014-03-21 13:52:34 +0000
commit9ca6ba8fcbf752dc4048bc687380744673da916b (patch)
tree35bd07e8e6cd95ba0dab999adf262702ce534429 /configure.ac
parent4745f485c43795f86006bd159388c28606c5ce07 (diff)
downloadcups-9ca6ba8fcbf752dc4048bc687380744673da916b.tar.gz
Rename configure.in to configure.ac.
Rename cups-launchd.m4 to cups-ondemand.m4 in preparation for systemd support. Add more files to the Xcode project. git-svn-id: svn+ssh://src.apple.com/svn/cups/cups.org/trunk@11715 a1ca3aef-8c08-0410-bb20-df032aa958be
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac96
1 files changed, 96 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 000000000..66badb52f
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,96 @@
+dnl
+dnl "$Id$"
+dnl
+dnl Configuration script for CUPS.
+dnl
+dnl Copyright 2007-2014 by Apple Inc.
+dnl Copyright 1997-2007 by Easy Software Products, all rights reserved.
+dnl
+dnl These coded instructions, statements, and computer programs are the
+dnl property of Apple Inc. and are protected by Federal copyright
+dnl law. Distribution and use rights are outlined in the file "LICENSE.txt"
+dnl which should have been included with this file. If this file is
+dnl file is missing or damaged, see the license at "http://www.cups.org/".
+dnl
+
+AC_INIT(cups/cups.h)
+
+sinclude(config-scripts/cups-opsys.m4)
+sinclude(config-scripts/cups-common.m4)
+sinclude(config-scripts/cups-directories.m4)
+sinclude(config-scripts/cups-manpages.m4)
+
+sinclude(config-scripts/cups-sharedlibs.m4)
+sinclude(config-scripts/cups-libtool.m4)
+sinclude(config-scripts/cups-compiler.m4)
+
+sinclude(config-scripts/cups-network.m4)
+sinclude(config-scripts/cups-poll.m4)
+sinclude(config-scripts/cups-gssapi.m4)
+sinclude(config-scripts/cups-threads.m4)
+sinclude(config-scripts/cups-ssl.m4)
+sinclude(config-scripts/cups-pam.m4)
+sinclude(config-scripts/cups-largefile.m4)
+sinclude(config-scripts/cups-dnssd.m4)
+sinclude(config-scripts/cups-ondemand.m4)
+sinclude(config-scripts/cups-defaults.m4)
+sinclude(config-scripts/cups-scripting.m4)
+
+INSTALL_LANGUAGES=""
+UNINSTALL_LANGUAGES=""
+LANGFILES=""
+if test "x$LANGUAGES" != x; then
+ INSTALL_LANGUAGES="install-languages"
+ UNINSTALL_LANGUAGES="uninstall-languages"
+ for lang in $LANGUAGES; do
+ if test -f doc/$lang/index.html.in; then
+ LANGFILES="$LANGFILES doc/$lang/index.html"
+ fi
+
+ if test -f templates/$lang/header.tmpl.in; then
+ LANGFILES="$LANGFILES templates/$lang/header.tmpl"
+ fi
+ done
+elif test "x$CUPS_BUNDLEDIR" != x; then
+ INSTALL_LANGUAGES="install-langbundle"
+ UNINSTALL_LANGUAGES="uninstall-langbundle"
+fi
+
+AC_SUBST(INSTALL_LANGUAGES)
+AC_SUBST(UNINSTALL_LANGUAGES)
+
+AC_OUTPUT(Makedefs
+ conf/cups-files.conf
+ conf/cupsd.conf
+ conf/mime.convs
+ conf/pam.std
+ conf/snmp.conf
+ cups-config
+ data/testprint
+ desktop/cups.desktop
+ doc/help/ref-cups-files-conf.html
+ doc/help/ref-cupsd-conf.html
+ doc/index.html
+ man/client.conf.man
+ man/cups-deviced.man
+ man/cups-driverd.man
+ man/cups-files.conf.man
+ man/cups-lpd.man
+ man/cups-snmp.man
+ man/cupsaddsmb.man
+ man/cupsd.conf.man
+ man/cupsd.man
+ man/lpoptions.man
+ scheduler/cups-lpd.xinetd
+ scheduler/cups.sh
+ scheduler/cups.xml
+ scheduler/org.cups.cups-lpd.plist
+ templates/header.tmpl
+ packaging/cups.list
+ $LANGFILES)
+
+chmod +x cups-config
+
+dnl
+dnl End of "$Id$".
+dnl