summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNick Banks <nibanks@microsoft.com>2022-04-10 18:21:37 +0200
committerDaniel Stenberg <daniel@haxx.se>2022-04-10 18:23:04 +0200
commit37492ebbfa24ba4e700e6655b3dbc2bdd65c894a (patch)
treee0850c91ec4a66c654463d2ede04cd9c038288fd /CMakeLists.txt
parent7befbe9ce97d6f9a1525a0fcbf5cbc5ad50546e3 (diff)
downloadcurl-37492ebbfa24ba4e700e6655b3dbc2bdd65c894a.tar.gz
msh3: add support for QUIC and HTTP/3 using msh3
Considered experimental, as the other HTTP/3 backends. Closes #8517
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b77de6d5e..6957f619d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -556,6 +556,16 @@ if(USE_QUICHE)
cmake_pop_check_state()
endif()
+option(USE_MSH3 "Use msquic library for HTTP/3 support" OFF)
+if(USE_MSH3)
+ if(USE_NGTCP2 OR USE_QUICHE)
+ message(FATAL_ERROR "Only one HTTP/3 backend can be selected!")
+ endif()
+ set(USE_MSH3 ON)
+ include_directories(${MSH3_INCLUDE_DIRS})
+ list(APPEND CURL_LIBS ${MSH3_LIBRARIES})
+endif()
+
if(NOT CURL_DISABLE_LDAP)
if(WIN32)
option(USE_WIN32_LDAP "Use Windows LDAP implementation" ON)