summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorViktor Szakats <commit@vsz.me>2022-05-26 15:54:20 +0000
committerViktor Szakats <commit@vsz.me>2022-05-26 15:54:20 +0000
commit435f395f3f8c11eebfcc243ca55ebcc11a19b8b8 (patch)
treefe0834086da771d2c067cf8ff112ec75eeebd009 /CMakeLists.txt
parent2e769766eab493ad15a74521b32aabe1f6f40f7c (diff)
downloadcurl-435f395f3f8c11eebfcc243ca55ebcc11a19b8b8.tar.gz
cmake: support adding a suffix to the OS value
CMake automatically uses the `CMAKE_SYSTEM_NAME` value to fill the OS string appearing in the --version output after the curl version number, for example: 'curl 7.83.1 (Windows)' This patchs adds the ability to pass a suffix that is appended to this value. It's useful to add CPU info or other platform details, for example: 'curl 7.83.1 (Windows-x64)' Closes #8919
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ee0cce08a..fb1b2210d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -65,7 +65,7 @@ message(STATUS "curl version=[${CURL_VERSION}]")
# SET(PACKAGE_STRING "curl-")
# SET(PACKAGE_BUGREPORT "a suitable curl mailing list => https://curl.se/mail/")
set(OPERATING_SYSTEM "${CMAKE_SYSTEM_NAME}")
-set(OS "\"${CMAKE_SYSTEM_NAME}\"")
+set(OS "\"${CMAKE_SYSTEM_NAME}${CURL_OS_SUFFIX}\"")
include_directories(${CURL_SOURCE_DIR}/include)