summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Stenberg <daniel@haxx.se>2021-03-08 12:30:56 +0100
committerDaniel Stenberg <daniel@haxx.se>2021-03-11 10:11:56 +0100
commit78f642ffab9a703bb23e4d9ddb1abe582f14eb62 (patch)
tree8b2d24c24f34dc1968dedcb612f81349960d4ce7 /CMakeLists.txt
parent6043dfa4f9471cf4f5da2492670aff26b16a94ab (diff)
downloadcurl-78f642ffab9a703bb23e4d9ddb1abe582f14eb62.tar.gz
config: remove CURL_SIZEOF_CURL_OFF_T use only SIZEOF_CURL_OFF_T
Make the code consistently use a single name for the size of the "curl_off_t" type. Closes #6702
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 62b2235cb..23db36f76 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1360,7 +1360,7 @@ _add_if("brotli" HAVE_BROTLI)
_add_if("zstd" HAVE_ZSTD)
_add_if("AsynchDNS" USE_ARES OR USE_THREADS_POSIX OR USE_THREADS_WIN32)
_add_if("IDN" HAVE_LIBIDN2)
-_add_if("Largefile" (CURL_SIZEOF_CURL_OFF_T GREATER 4) AND
+_add_if("Largefile" (SIZEOF_CURL_OFF_T GREATER 4) AND
((SIZEOF_OFF_T GREATER 4) OR USE_WIN32_LARGE_FILES))
# TODO SSP1 (Schannel) check is missing
_add_if("SSPI" USE_WINDOWS_SSPI)