summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarcel Raad <Marcel.Raad@teamviewer.com>2021-09-18 01:25:20 +0200
committerMarcel Raad <Marcel.Raad@teamviewer.com>2021-09-28 19:29:27 +0200
commitc2ea04f92b00b6271627cb218647527b5a50f2fc (patch)
tree7240ef0000633673b5c11bdddcd72a224d3a113c /CMakeLists.txt
parentacfe94c08f2573edc2ae52bf0097130deea299ff (diff)
downloadcurl-c2ea04f92b00b6271627cb218647527b5a50f2fc.tar.gz
build: remove checks for WinSock 1
It's not supported anymore. Closes https://github.com/curl/curl/pull/7778
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index cf9c390c3..58e3c0366 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -910,7 +910,6 @@ endif()
# Check for header files
if(NOT UNIX)
check_include_file_concat("windows.h" HAVE_WINDOWS_H)
- check_include_file_concat("winsock.h" HAVE_WINSOCK_H)
check_include_file_concat("ws2tcpip.h" HAVE_WS2TCPIP_H)
check_include_file_concat("winsock2.h" HAVE_WINSOCK2_H)
check_include_file_concat("wincrypt.h" HAVE_WINCRYPT_H)