summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Pastor <dg0yt@darc.de>2022-07-02 09:36:09 +0200
committerJay Satiro <raysatiro@yahoo.com>2022-07-03 00:04:57 -0400
commite584b1c0445b7f72cdd48ccd8f51d01a642a1a99 (patch)
tree9863a79d03fecf194ef421e09e7b884aa19decf0 /CMakeLists.txt
parentbbffb8c285bad68350df12405ef67056e7cbfc47 (diff)
downloadcurl-e584b1c0445b7f72cdd48ccd8f51d01a642a1a99.tar.gz
cmake: fix build for mingw cross compile
- Change normaliz lib name to all lowercase. This is from a standing patch in vcpkg: Mingw has libnormaliz.a. For case-sensitive file systems (e.g. cross builds from Linux), the spelling must match exactly. Closes https://github.com/curl/curl/pull/9084
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ad20777f3..5f93bedf6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -688,7 +688,7 @@ endif()
if(WIN32)
option(USE_WIN32_IDN "Use WinIDN for IDN support" OFF)
if(USE_WIN32_IDN)
- list(APPEND CURL_LIBS "Normaliz")
+ list(APPEND CURL_LIBS "normaliz")
set(WANT_IDN_PROTOTYPES ON)
endif()
endif()