summaryrefslogtreecommitdiff
path: root/Demos/setup.py
diff options
context:
space:
mode:
authorRobert Bradshaw <robertwb@math.washington.edu>2009-04-02 12:08:37 -0700
committerRobert Bradshaw <robertwb@math.washington.edu>2009-04-02 12:08:37 -0700
commit2f08050bf9c825a50419d02d6da6bb5a8ab48744 (patch)
tree58443fe9136d2bd09b3eee5018dcf098473a8a8f /Demos/setup.py
parent326f530dda2b2e4c243ab9d69da5349778517d43 (diff)
downloadcython-2f08050bf9c825a50419d02d6da6bb5a8ab48744.tar.gz
Demos/Setup.py -> Demos/setup.py
--HG-- rename : Demos/Setup.py => Demos/setup.py
Diffstat (limited to 'Demos/setup.py')
-rw-r--r--Demos/setup.py20
1 files changed, 20 insertions, 0 deletions
diff --git a/Demos/setup.py b/Demos/setup.py
new file mode 100644
index 000000000..75b05af0f
--- /dev/null
+++ b/Demos/setup.py
@@ -0,0 +1,20 @@
+import glob
+
+from distutils.core import setup
+from distutils.extension import Extension
+from Cython.Distutils import build_ext
+
+ext_modules=[
+ Extension("primes", ["primes.pyx"]),
+ Extension("spam", ["spam.pyx"]),
+]
+
+for file in glob.glob("*.pyx"):
+ if file != "numeric_demo.pyx":
+ ext_modules.append(Extension(file[:-4], [file]))
+
+setup(
+ name = 'Demos',
+ cmdclass = {'build_ext': build_ext},
+ ext_modules = ext_modules,
+)