summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2018-11-24 11:08:26 +0100
committerStefan Behnel <stefan_ml@behnel.de>2018-11-24 11:08:26 +0100
commit8c490265b8c2b23e8680068c9d18210e5f82c8e7 (patch)
treeb1a281a9d05b792f9ae149bc41224edb089dc760 /setup.py
parent34eac74e30021e28b5f87cd0e4db2d9b03ca93e1 (diff)
downloadcython-8c490265b8c2b23e8680068c9d18210e5f82c8e7.tar.gz
Remove Py2.6/3.3 compatibility markers from setup.py metadata.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py3
1 files changed, 1 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index a94fc0d39..d0743bb13 100755
--- a/setup.py
+++ b/setup.py
@@ -14,7 +14,7 @@ is_cpython = platform.python_implementation() == 'CPython'
# this specifies which versions of python we support, pip >= 9 knows to skip
# versions of packages which are not compatible with the running python
-PYTHON_REQUIRES = '>=2.6, !=3.0.*, !=3.1.*, !=3.2.*'
+PYTHON_REQUIRES = '>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*'
if sys.platform == "darwin":
# Don't create resource files on OS X tar.
@@ -263,7 +263,6 @@ setup(
"Operating System :: OS Independent",
"Programming Language :: Python",
"Programming Language :: Python :: 2",
- "Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
"Programming Language :: Python :: 3",
"Programming Language :: Python :: 3.4",