summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2017-08-21 19:14:56 +0200
committerStefan Behnel <stefan_ml@behnel.de>2017-08-21 19:14:56 +0200
commitf4faa0ee50916d5e042493827062a47ae6b1d988 (patch)
tree9f95e256b333f8c1fe83885fe46d44fd4792d6f4 /setup.py
parent86495ff725fdb871b25b47f7efe20ba673cb066f (diff)
downloadcython-f4faa0ee50916d5e042493827062a47ae6b1d988.tar.gz
Revert "Do not compile Lexicon.py. It's really only used once and is much larger as a binary module than as a byte code file, but not slower to import."
Currently seems to be required when the scanner is compiled. This reverts commit d66405c66edd52cdb7befe0e5797248ae5ac44ae.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index b96069199..6e912ebec 100755
--- a/setup.py
+++ b/setup.py
@@ -101,6 +101,7 @@ def compile_cython_modules(profile=False, compile_more=False, cython_with_refnan
compiled_modules = [
"Cython.Plex.Scanners",
"Cython.Plex.Actions",
+ "Cython.Compiler.Lexicon",
"Cython.Compiler.Scanning",
"Cython.Compiler.Parsing",
"Cython.Compiler.Visitor",
@@ -113,7 +114,6 @@ def compile_cython_modules(profile=False, compile_more=False, cython_with_refnan
if compile_more:
compiled_modules.extend([
"Cython.Build.Dependencies",
- "Cython.Compiler.Lexicon",
"Cython.Compiler.ParseTreeTransforms",
"Cython.Compiler.Nodes",
"Cython.Compiler.ExprNodes",