summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorpdurante <pdurante@30a43799-04e7-0310-8b2b-ea0d24f86d0e>2006-12-31 05:16:32 +0000
committerpdurante <pdurante@30a43799-04e7-0310-8b2b-ea0d24f86d0e>2006-12-31 05:16:32 +0000
commit7835d90bdc5de6d82d14e98a570f8cc8300fcee2 (patch)
treecc54dedd657289852568937fa7ba6a1dbe52b47d /configure.ac
parent12266bd407e85c7468bc9dfd2284dfebdc9a9430 (diff)
downloaddbus-c++-7835d90bdc5de6d82d14e98a570f8cc8300fcee2.tar.gz
* Renamed pkg-config configuration file
* Initial support for out-of-tree builds and crosscompilation (Robert Schwebel) git-svn-id: http://dev.openwengo.org/svn/openwengo/wengophone-ng/branches/wengophone-dbus-api/libs/dbus@9043 30a43799-04e7-0310-8b2b-ea0d24f86d0e
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac19
1 files changed, 18 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 7385105..ccbf569 100644
--- a/configure.ac
+++ b/configure.ac
@@ -30,6 +30,9 @@ AC_LANG_CPLUSPLUS
AC_PROG_CC
AC_PROG_CXX
+CXX_FOR_BUILD=${CXX_FOR_BUILD-${CXX}}
+AC_SUBST(CXX_FOR_BUILD)
+
AM_PROG_LIBTOOL
PKG_PROG_PKG_CONFIG
@@ -92,6 +95,20 @@ fi
AM_CONDITIONAL(DBUS_DOXYGEN_DOCS_ENABLED, test x$enable_doxygen_docs = xyes)
AC_MSG_RESULT(yes)
+
+# For the tools/, we need libdbus-c++ for the "build" architecture as well
+
+AM_CONDITIONAL(CROSS_COMPILING, test $cross_compiling = yes)
+
+AC_ARG_WITH(build-libdbus-cxx,
+ AS_HELP_STRING([--with-build-libdbus-cxx],[For cross compilation: path to
+ libdbus-cxx which was compiled for the 'build' system.]),
+ [ BUILD_LIBDBUS_CXX_DIR=${withval} ],
+ [ BUILD_LIBDBUS_CXX_DIR="\$(top_builddir)" ]
+)
+AC_SUBST(BUILD_LIBDBUS_CXX_DIR)
+
+
# Save processed files
AC_OUTPUT(
@@ -105,5 +122,5 @@ AC_OUTPUT(
examples/properties/Makefile
examples/echo/Makefile
examples/hal/Makefile
- dbus-c++.pc
+ dbus-c++-1.pc
)