summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorpdurante <pdurante@30a43799-04e7-0310-8b2b-ea0d24f86d0e>2006-12-31 02:03:53 +0000
committerpdurante <pdurante@30a43799-04e7-0310-8b2b-ea0d24f86d0e>2006-12-31 02:03:53 +0000
commit12266bd407e85c7468bc9dfd2284dfebdc9a9430 (patch)
treeeab68f058c2f383b8ece447ad3c733187c85d30c /src/Makefile.am
parentd74a45890aac40a42f8eba4a4132a78162fd0f49 (diff)
downloaddbus-c++-12266bd407e85c7468bc9dfd2284dfebdc9a9430.tar.gz
* Bumped version number to 0.5.0
* Updated copyright notice to the upcoming year * Some s/DBus/D-Bus/g in the comments * Updated TODO list * Removed hardcoded version number from output file names * Added --enable-debug switch to ./configure (debug mode is now off by default) * Reordered autogen.sh (Robert Schwebel) * Removed autogenerated files (Robert Schwebel) * Fixed 'make maintainer-clean' (Robert Schebel) git-svn-id: http://dev.openwengo.org/svn/openwengo/wengophone-ng/branches/wengophone-dbus-api/libs/dbus@9042 30a43799-04e7-0310-8b2b-ea0d24f86d0e
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am18
1 files changed, 12 insertions, 6 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index de13f54..3962aca 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,5 +1,8 @@
-INCLUDES = $(dbus_CFLAGS) $(xml_CFLAGS) -I$(top_srcdir)/include
-AM_CPPFLAGS = -DDBUS_API_SUBJECT_TO_CHANGE
+AM_CPPFLAGS = \
+ $(dbus_CFLAGS) \
+ $(xml_CFLAGS) \
+ -I$(top_srcdir)/include \
+ -DDBUS_API_SUBJECT_TO_CHANGE
HEADER_DIR = $(top_srcdir)/include/dbus-c++
HEADER_FILES = \
@@ -23,9 +26,12 @@ HEADER_FILES = \
$(HEADER_DIR)/xml.h \
$(HEADER_DIR)/introspection.h
-lib_includedir=$(includedir)/dbus-c++-0.3/dbus-c++
+lib_includedir=$(includedir)/dbus-c++-1/dbus-c++/
lib_include_HEADERS = $(HEADER_FILES)
-lib_LTLIBRARIES = libdbus-c++-0.3.la
-libdbus_c___0_3_la_SOURCES = $(HEADER_FILES) interface.cpp object.cpp introspection.cpp debug.cpp eventloop.cpp xml.cpp types.cpp connection.cpp connection_p.h property.cpp dispatcher.cpp dispatcher_p.h pendingcall.cpp pendingcall_p.h error.cpp internalerror.h message.cpp message_p.h server.cpp server_p.h
-libdbus_c___0_3_la_LIBADD = $(dbus_LIBS) $(xml_LIBS)
+lib_LTLIBRARIES = libdbus-c++-1.la
+libdbus_c___1_la_SOURCES = $(HEADER_FILES) interface.cpp object.cpp introspection.cpp debug.cpp eventloop.cpp xml.cpp types.cpp connection.cpp connection_p.h property.cpp dispatcher.cpp dispatcher_p.h pendingcall.cpp pendingcall_p.h error.cpp internalerror.h message.cpp message_p.h server.cpp server_p.h
+libdbus_c___1_la_LIBADD = $(dbus_LIBS) $(xml_LIBS)
+
+MAINTAINERCLEANFILES = \
+ Makefile.in