summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorpdurante <pdurante@30a43799-04e7-0310-8b2b-ea0d24f86d0e>2007-07-23 18:31:49 +0000
committerpdurante <pdurante@30a43799-04e7-0310-8b2b-ea0d24f86d0e>2007-07-23 18:31:49 +0000
commit7c420f87cd3274a4e685e7a5abf972d03f29414b (patch)
treef51a8b4162660c1a2510812f169cc249cc8cb045 /src/Makefile.am
parenta8f5e819bd37b0d9f53e9cc003be5043546e5c5a (diff)
downloaddbus-c++-7c420f87cd3274a4e685e7a5abf972d03f29414b.tar.gz
* Enabled the symbol visibility feature from gcc 4, reduces binary size and dynamic loading speed
* A lot of fixes to keep compatibility with older (0.6x) versions of libdbus * Moved the xml handling code from the library to the code generator * Rewrote the routine to generate introspection data * Autojunk cleanup git-svn-id: http://dev.openwengo.org/svn/openwengo/wengophone-ng/branches/wengophone-dbus-api/libs/dbus@12019 30a43799-04e7-0310-8b2b-ea0d24f86d0e
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am7
1 files changed, 3 insertions, 4 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index aa850b2..f7e5617 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -1,6 +1,5 @@
AM_CPPFLAGS = \
$(dbus_CFLAGS) \
- $(xml_CFLAGS) \
$(glib_CFLAGS) \
-I$(top_srcdir)/include
@@ -28,16 +27,16 @@ HEADER_FILES = \
$(HEADER_DIR)/debug.h \
$(HEADER_DIR)/util.h \
$(HEADER_DIR)/refptr_impl.h \
- $(HEADER_DIR)/xml.h \
$(HEADER_DIR)/introspection.h \
+ $(HEADER_DIR)/api.h \
$(GLIB_H)
lib_includedir=$(includedir)/dbus-c++-1/dbus-c++/
lib_include_HEADERS = $(HEADER_FILES)
lib_LTLIBRARIES = libdbus-c++-1.la
-libdbus_c___1_la_SOURCES = $(HEADER_FILES) interface.cpp object.cpp introspection.cpp debug.cpp eventloop.cpp xml.cpp types.cpp connection.cpp connection_p.h property.cpp dispatcher.cpp dispatcher_p.h pendingcall.cpp pendingcall_p.h error.cpp internalerror.h message.cpp message_p.h server.cpp server_p.h $(GLIB_CPP)
-libdbus_c___1_la_LIBADD = $(dbus_LIBS) $(xml_LIBS) $(glib_LIBS)
+libdbus_c___1_la_SOURCES = $(HEADER_FILES) interface.cpp object.cpp introspection.cpp debug.cpp eventloop.cpp types.cpp connection.cpp connection_p.h property.cpp dispatcher.cpp dispatcher_p.h pendingcall.cpp pendingcall_p.h error.cpp internalerror.h message.cpp message_p.h server.cpp server_p.h $(GLIB_CPP)
+libdbus_c___1_la_LIBADD = $(dbus_LIBS) $(glib_LIBS)
MAINTAINERCLEANFILES = \
Makefile.in