summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorJohn (J5) Palmieri <johnp@redhat.com>2006-07-21 16:25:35 -0400
committerJohn Palmieri <johnp@remedyz.boston.redhat.com>2006-07-21 16:25:35 -0400
commit3f720d5a5028d2b4075b474ba17fb9b7508093ac (patch)
tree5df21350d4ffbb8dffd01aedfa759228a14003a5 /Makefile.am
parent05cb3fd6e2c139e61d1461443660badfbdf94a83 (diff)
downloaddbus-glib-3f720d5a5028d2b4075b474ba17fb9b7508093ac.tar.gz
* Various Makefile cleanups
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am26
1 files changed, 24 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index 7bea59c..c484934 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,7 +1,7 @@
GLIB_PC=dbus-glib-1.pc
-SUBDIRS=dbus test tools
-DIST_SUBDIRS=dbus test tools
+SUBDIRS=dbus tools test
+DIST_SUBDIRS=dbus tools test
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = $(GLIB_PC)
@@ -14,6 +14,28 @@ EXTRA_DIST = \
NEWS \
dbus-glib-1.pc.in
+# Creating ChangeLog from git log:
+
+MAINTAINERCLEANFILES = ChangeLog
+
+EXTRA_DIST += ChangeLog
+
+.PHONY: ChangeLog $(srcdir)/ChangeLog
+ChangeLog: $(srcdir)/ChangeLog
+$(srcdir)/ChangeLog:
+ @if test -d "$(srcdir)/.git"; then \
+ (cd "$(srcdir)" && \
+ ./missing --run git-log --stat) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
all-local: Doxyfile
if DBUS_GCOV_ENABLED