summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2011-04-20 16:41:00 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2011-05-30 15:41:53 +0100
commit9e2031148fd0ee114ec67c681d2b9bcfd84cdaa4 (patch)
tree94a1fb8b5ec0753ee7920abf990b6645dd05de8c /Makefile.am
parent61f48c290176c007ff0aef6ca4d752491763e4b0 (diff)
downloaddbus-glib-9e2031148fd0ee114ec67c681d2b9bcfd84cdaa4.tar.gz
add a Makefile rule to upload a tarball and up-to-date docs
Simplified from telepathy-glib, which has more elaborate machinery to automate releases. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=26952 Reviewed-by: Guillaume Desmottes <guillaume.desmottes@collabora.co.uk>
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 8bd2381..278daed 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -40,4 +40,16 @@ $(srcdir)/ChangeLog:
all-local: Doxyfile
+%.tar.gz.asc: %.tar.gz
+ $(AM_V_GEN)gpg --detach-sign --armor $@
+
+maintainer-upload-release:
+ test -f @PACKAGE@-@VERSION@.tar.gz
+ test -f @PACKAGE@-@VERSION@.tar.gz.asc
+ gpg --verify @PACKAGE@-@VERSION@.tar.gz.asc
+ rsync -vzP @PACKAGE@-@VERSION@.tar.gz dbus.freedesktop.org:/srv/dbus.freedesktop.org/www/releases/@PACKAGE@/@PACKAGE@-@VERSION@.tar.gz
+ rsync -vzP @PACKAGE@-@VERSION@.tar.gz.asc dbus.freedesktop.org:/srv/dbus.freedesktop.org/www/releases/@PACKAGE@/@PACKAGE@-@VERSION@.tar.gz.asc
+ rsync -rvzPp --chmod=Dg+s,ug+rwX,o=rX $(srcdir)/docs/reference/html/ \
+ dbus.freedesktop.org:/srv/dbus.freedesktop.org/www/doc/@PACKAGE@/
+
include tools/lcov.am