summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorSimon McVittie <simon.mcvittie@collabora.co.uk>2014-09-16 13:32:45 +0100
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2015-02-09 14:32:55 +0000
commitb5528d7ff526d700aab5b9e11aed871180d4f81e (patch)
treec83168ab9d5cca7235d847ab16028d971acb6592 /configure.ac
parentc0d1ffc09b5b008fe9b3ee09330ad663927669af (diff)
downloaddbus-glib-b5528d7ff526d700aab5b9e11aed871180d4f81e.tar.gz
Require a modern libdbus and a modern GLib
This means we can assume that GLib and libdbus are thread-safe by default. Also explicitly document that the object-mapping layer of dbus-glib is not thread-safe. Bug: https://bugs.freedesktop.org/show_bug.cgi?id=64214 Reviewed-by: Colin Walters <walters@verbum.org> [with review comments to be fixed in subsequent commit -smcv]
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac7
1 files changed, 2 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 7891ce6..999e00f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -259,15 +259,12 @@ XML_CFLAGS=
#### Set up final flags
-PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.2.16])
+PKG_CHECK_MODULES([DBUS], [dbus-1 >= 1.8])
AC_SUBST([DBUS_CFLAGS])
AC_SUBST([DBUS_LIBS])
# Glib detection
-PKG_CHECK_MODULES([DBUS_GLIB], [gobject-2.0 >= 2.26, gio-2.0 >= 2.26])
-PKG_CHECK_MODULES(DBUS_GLIB_THREADS, gthread-2.0 >= 2.6, have_glib_threads=yes, have_glib_threads=no)
-
-AM_CONDITIONAL(HAVE_GLIB_THREADS, test x$have_glib_threads = xyes)
+PKG_CHECK_MODULES([DBUS_GLIB], [gobject-2.0 >= 2.32, gio-2.0 >= 2.32, gthread-2.0 >= 2.32])
GLIB_GENMARSHAL=`$PKG_CONFIG --variable=glib_genmarshal glib-2.0`
AC_SUBST(GLIB_GENMARSHAL)