summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2019-03-07 13:41:53 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2019-03-13 08:56:59 +0100
commit14083a42cc28b98e5fe1db370ad0c8d597e7def5 (patch)
tree11dcd90131d7922cc981bcb60ace67be4cac6de5 /CMakeLists.txt
parent10b2cd53fb83ebd86832a188a6fe6f44b0fcddba (diff)
downloaddbus-14083a42cc28b98e5fe1db370ad0c8d597e7def5.tar.gz
cmake: Enable pkg-config generating also on Windows
pkgconfig support is used by client packages on cross compiled obs builds.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 9bc10550..a5859935 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -89,6 +89,7 @@ set(DATADIR_FROM_PKGSYSCONFDIR ${CMAKE_INSTALL_FULL_DATADIR})
endif()
option(DBUS_RELOCATABLE "Attempt to make metadata relocatable" ON)
+option(DBUS_ENABLE_PKGCONFIG "Enable pkgconfig support" ON)
# For simplicity, we're not relocatable if CMAKE_INSTALL_LIBDIR
# is something more complicated (e.g. Debian multiarch);
@@ -671,7 +672,7 @@ add_custom_target(help-options
#
# create pkgconfig file
#
-if(UNIX)
+if(DBUS_ENABLE_PKGCONFIG)
set(PLATFORM_LIBS pthread ${LIBRT})
include(FindPkgConfig QUIET)
if(PKG_CONFIG_FOUND)