summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2022-04-07 14:54:29 +0200
committerSimon McVittie <smcv@collabora.com>2022-04-21 13:56:26 +0100
commit4b73505869d9dbafd255c182abe867290c4f72e6 (patch)
tree37a37932b84ec1fb13ed0828b2948c26ad52c0b0 /CMakeLists.txt
parentb90b838c93fbfba4476901fddcff50d23cd4b108 (diff)
downloaddbus-4b73505869d9dbafd255c182abe867290c4f72e6.tar.gz
Ignore gcc 10.3 'inline' warnings: 'call is unlikely and code size would grow'
As long as gcc does something with compatible semantics, it is up to gcc how to optimize our code. The alternative would be to export the functions in question from the shared library, which has the disadvantage of greatly increasing the number of calls across a shared library boundary. Part-of: https://gitlab.freedesktop.org/dbus/dbus/-/merge_requests/275 Reviewed-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c7fc6f2a..197b095d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -338,6 +338,7 @@ else()
error=null-dereference
error=strict-aliasing
error=unused-parameter
+ inline
unused-parameter
)
set(WARNINGS_ERRORS