summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Richardson <arichardson@FreeBSD.org>2022-08-14 16:28:56 +0000
committerSimon McVittie <smcv@collabora.com>2022-09-21 11:35:05 +0000
commit6933a9263e30e2dbfb36a038660b9387ee632d32 (patch)
tree645ee67bafdb5f4283d63157b820c0c2461c83bf /CMakeLists.txt
parent91f4ac9cf62f8bb99c28ddfa4f376e45fd1b2b94 (diff)
downloaddbus-6933a9263e30e2dbfb36a038660b9387ee632d32.tar.gz
dbus-message.c: skip 1.10 layout compatibility test on new architectures
These static assertions fail on CHERI-enabled architectures such as Arm Morello, where pointers are 128 bits. Architectures with 128-bit pointers were not supported in DBus 1.10, so we can skip the checks for DBus 1.10 structure layout compatibility for architectures with pointer size > 64 bit.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 58ed3d89..28017a4e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -735,6 +735,7 @@ message(" cxxflags release: ${CMAKE_CXX_FLAGS_RELEASE} "
message(" 64-bit int: ${DBUS_INT64_TYPE} ")
message(" 32-bit int: ${DBUS_INT32_TYPE} ")
message(" 16-bit int: ${DBUS_INT16_TYPE} ")
+message(" pointer size: ${DBUS_SIZEOF_VOID_P} ")
message(" Doxygen: ${DOXYGEN} ")
message(" Docbook Generator: ${DOCBOOK_GENERATOR_NAME} ")