summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2018-10-16 22:47:18 +0200
committerSimon McVittie <smcv@collabora.com>2021-11-18 12:52:22 +0000
commit6b41f053c59c942f8c6dfa6eafc415a63d30edf1 (patch)
tree8a7002438159cd9e251038305d283461be4f7948 /CMakeLists.txt
parent541dbab907938e3bb1836e8994680d303f16381c (diff)
downloaddbus-6b41f053c59c942f8c6dfa6eafc415a63d30edf1.tar.gz
Move _GNU_SOURCE to config.h.cmake
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 44b437c1..da0ccf88 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -197,7 +197,7 @@ if(GLIB2_FOUND)
endif()
# analogous to AC_USE_SYSTEM_EXTENSIONS in configure.ac
-add_definitions(-D_GNU_SOURCE)
+set(_GNU_SOURCE 1)
# do config checks
include(ConfigureChecks)