summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2022-03-03 09:48:51 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2022-03-04 08:14:44 +0100
commit6c21072a1e7832783b77dfde8d95ddf1e5927b98 (patch)
tree9b042d66f3035a2506a3b1dc9494c3ca1e88a950 /CMakeLists.txt
parenta0040b9cefac0b67a47633b8cec55c0cd6b43c24 (diff)
downloaddbus-6c21072a1e7832783b77dfde8d95ddf1e5927b98.tar.gz
cmake: Set DBUS_*_CONFIG_FILE to be in datadir on Unix
The files were installed to the datadir (usually /usr/share) since commit 70950325, but the macros used to implement dbus-daemon --system and dbus-daemon --session still looked for them in the sysconfdir (usually /etc). Fixes: 70950325 "Adjust cmake build to match autoconf installation locations"
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a29bddcf..210e5311 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -610,10 +610,8 @@ if(WIN32)
else(WIN32)
set(DBUS_SESSION_BUS_LISTEN_ADDRESS "unix:tmpdir=${DBUS_SESSION_SOCKET_DIR}" CACHE STRING "session bus default listening address")
set(DBUS_SESSION_BUS_CONNECT_ADDRESS "autolaunch:" CACHE STRING "session bus fallback address for clients")
- set(sysconfdir "")
- set(configdir ${sysconfdir}/dbus-1 )
- set(DBUS_SYSTEM_CONFIG_FILE ${configdir}/system.conf)
- set(DBUS_SESSION_CONFIG_FILE ${configdir}/session.conf)
+ set(DBUS_SYSTEM_CONFIG_FILE ${DBUS_DATADIR}/system.conf)
+ set(DBUS_SESSION_CONFIG_FILE ${DBUS_DATADIR}/session.conf)
set(DBUS_USER "messagebus")
set(DBUS_TEST_USER "nobody")
# For best security, assume that all non-Windows platforms can do