summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2021-12-06 12:22:58 +0100
committerSimon McVittie <smcv@collabora.com>2021-12-10 14:16:52 +0000
commit77375263f5a2eaac8dd2f6708109c519e74a3604 (patch)
treef091fd9811befae60ee70e7391143cb4476f8d41 /CMakeLists.txt
parent203e8a4d757e38d3ff3ddc9acfb608028249e3c6 (diff)
downloaddbus-77375263f5a2eaac8dd2f6708109c519e74a3604.tar.gz
cmake: add option ENABLE_VERBOSE_CONFIG
Checking the filenames of generated configuration files is now optionally possible with this cmake option. They are no longer displayed by default to avoid unnecessarily flooding the output.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3b57e4e0..c9b3784b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -96,6 +96,7 @@ endif()
option(DBUS_RELOCATABLE "Attempt to make metadata relocatable" ON)
option(DBUS_ENABLE_PKGCONFIG "Enable pkgconfig support" ON)
+option(ENABLE_VERBOSE_CONFIG "Be verbose on generating config files" OFF)
# For simplicity, we're not relocatable if CMAKE_INSTALL_LIBDIR
# is something more complicated (e.g. Debian multiarch);