summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2022-01-03 21:48:05 +0400
committerMarc-André Lureau <marcandre.lureau@redhat.com>2022-01-21 21:16:45 +0400
commitb0d418a51b9187eb6de93eb7c03416e8f2376e9b (patch)
tree2144e40e6a613aa782139e6d853e4b24dd32284e /CMakeLists.txt
parentd90ad99648661c21db75f6310e3374517fb36905 (diff)
downloaddbus-b0d418a51b9187eb6de93eb7c03416e8f2376e9b.tar.gz
cmake: fix warnings variables
Do not use strings for compiler flags. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d9a5eac1..713e8534 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -257,12 +257,12 @@ if(MSVC)
# see https://msdn.microsoft.com/en-us/library/z78503e6.aspx
# 4018 'expression' : signed/unsigned mismatch
- set(WARNINGS "4018")
+ set(WARNINGS 4018)
# 4090 'operation' : different 'modifier' qualifiers
# 4101 'identifier' : unreferenced local variable
# 4127 conditional expression is constant
# 4244 'argument' : conversion from 'type1' to 'type2', possible loss of data
- set(WARNINGS_DISABLED "4090 4101 4127 4244")
+ set(WARNINGS_DISABLED 4090 4101 4127 4244)
# 4002 too many actual parameters for macro 'identifier'
# 4003 not enough actual parameters for macro 'identifier'
# 4013 'function' undefined; assuming extern returning int
@@ -271,7 +271,7 @@ if(MSVC)
# 4047 operator' : 'identifier1' differs in levels of indirection from 'identifier2'
# 4114 same type qualifier used more than once
# 4133 'type' : incompatible types - from 'type1' to 'type2'
- set(WARNINGS_ERRORS "4002 4003 4013 4028 4031 4047 4114 4133")
+ set(WARNINGS_ERRORS 4002 4003 4013 4028 4031 4047 4114 4133)
if(DBUS_MSVC_ANALYZE AND MSVC_VERSION GREATER 1600)
string(APPEND CMAKE_C_FLAGS " /analyze")
endif()