summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc-André Lureau <marcandre.lureau@redhat.com>2022-07-06 15:58:37 +0400
committerMarc-André Lureau <marcandre.lureau@redhat.com>2022-07-06 15:58:39 +0400
commitc79d428564f974452b720264065d609281a97132 (patch)
treeb2d91878e6b5027a444c6c443fa60cae23b82810 /CMakeLists.txt
parent505233a57f2c9ce7fe468b115aedb1787c2a8037 (diff)
downloaddbus-c79d428564f974452b720264065d609281a97132.tar.gz
cmake: use -gdwarf-2
GCC 10.2.0 complains on opensuse mingw builds, ex: disable-crash-handling.c: error: STABS debugging information is obsolete and not supported anymore [-Werror] According to https://gitlab.freedesktop.org/dbus/dbus/-/issues/133#note_129599, -gdwarf-2 is the second best option. Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0914f07b..47953aa3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -376,8 +376,8 @@ string(APPEND CMAKE_CXX_FLAGS " ${WARNINGS_CXXFLAGS}")
# let wine be able to show file and lines in backtrace
if(DBUS_USE_WINE)
- string(APPEND CMAKE_C_FLAGS " -gstabs")
- string(APPEND CMAKE_CXX_FLAGS " -gstabs")
+ string(APPEND CMAKE_C_FLAGS " -gdwarf-2")
+ string(APPEND CMAKE_CXX_FLAGS " -gdwarf-2")
endif()
if(UNIX AND NOT DBUS_DISABLE_ASSERT)