summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Richardson <arichardson.kde@gmail.com>2022-03-19 14:48:04 +0000
committerAlex Richardson <arichardson.kde@gmail.com>2022-03-19 14:50:31 +0000
commitd4dbde9fc5bb217fe279b162195961552837fcca (patch)
tree574b87bcac3c6f7a932f66f99a1f44841055f8e4 /CMakeLists.txt
parent25c0aff7e8223d95da27e0afb1f3c390208fd072 (diff)
downloaddbus-d4dbde9fc5bb217fe279b162195961552837fcca.tar.gz
Revert "Fix gcc compile error: redundant redeclaration of ‘environ’ [-Werror=redundant-decls]"
Breaks the build on FreeBSD which doens't have an environ declaration. The CMake check_symbol_exists call sets `HAVE_DECL_ENVIRON` to an empty variable (which means if(DEFINED) suceeds). This normalization should not be necessary as it will be handled correctly by `#cmakedefine01`. If not, all the other HAVE_* defines would also be wrong. This reverts commit e8b34b419e44e0b95622f45c0f17487e241b1961.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 210e5311..66590792 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -625,11 +625,6 @@ set(DBUS_DAEMON_NAME "dbus-daemon" CACHE STRING "The name of the dbus daemon exe
#include(ConfigureChecks.cmake)
-# only defined but expected as boolean
-if(DEFINED HAVE_DECL_ENVIRON)
- set(HAVE_DECL_ENVIRON 1)
-endif()
-
# compiler definitions
add_definitions(-DHAVE_CONFIG_H)
add_definitions(${DBUS_BUS_CFLAGS})