summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2021-11-10 00:49:21 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2021-11-10 00:49:21 +0100
commitdccd628321b9f47ab0971f059c0f6baf74a843e7 (patch)
treeae3c92e5e7b985b1ddae47e33eb576a167a9a15a /CMakeLists.txt
parent3a3aae70fd6c68294b4da31c4c30dc29b7398e8b (diff)
downloaddbus-dccd628321b9f47ab0971f059c0f6baf74a843e7.tar.gz
cmake: fix find_package related naming mismatch for GLIB2
The package name passed to `find_package_handle_standard_args` (GLIB2) did not match the name of the calling package (GLib2). This could lead to problems when calling code that expects `find_package`. result variables (e.g. `_FOUND`) expect to follow a certain pattern. fixes #319
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d86b8ac4..dc5d60d6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -191,7 +191,7 @@ endif()
find_package(EXPAT)
find_package(X11)
-find_package(GLib2)
+find_package(GLIB2)
if(GLIB2_FOUND)
option(DBUS_WITH_GLIB "build with glib" ON)
endif()