summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2021-11-30 10:14:05 +0100
committerRalf Habacker <ralf.habacker@freenet.de>2021-11-30 14:35:01 +0100
commite8b34b419e44e0b95622f45c0f17487e241b1961 (patch)
tree0bc96e3a8f21453bd34f4786fd306455ab0caadd /CMakeLists.txt
parent05cc895444e58bdd2d83a1aeb3eee978c377d2c2 (diff)
downloaddbus-e8b34b419e44e0b95622f45c0f17487e241b1961.tar.gz
Fix gcc compile error: redundant redeclaration of ‘environ’ [-Werror=redundant-decls]
Cherry picked from dbus/dbus!227
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 3d382403..8b0cdf42 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -545,6 +545,11 @@ set(DBUS_DAEMON_NAME "dbus-daemon" CACHE STRING "The name of the dbus daemon exe
#include(ConfigureChecks.cmake)
+# only defined but expected as boolean
+if(DEFINED HAVE_DECL_ENVIRON)
+ set(HAVE_DECL_ENVIRON 1)
+endif()
+
# compiler definitions
add_definitions(-DHAVE_CONFIG_H)
add_definitions(${DBUS_BUS_CFLAGS})