summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlex Richardson <arichardson.kde@gmail.com>2022-04-01 11:09:45 +0000
committerSimon McVittie <smcv@collabora.com>2022-04-19 11:52:22 +0000
commitf4876e7cb5815f5d329f9517d96a1df88688cf9f (patch)
tree64698ccd1a18ff5d0bb51d33f68ce70ecd1a7309 /CMakeLists.txt
parent9506ff72192d1405ed0474005757a0210299fafd (diff)
downloaddbus-f4876e7cb5815f5d329f9517d96a1df88688cf9f.tar.gz
cmake: Correct DBUS_{SYSTEM,SESSION}_CONFIG_FILE on UNIX systems
We always install to a dbus-1 subdir, but the path encoded in the binary was missing the dbus-1/ subdirectory, so we end up getting errors when trying to load it.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99f102c5..c7fc6f2a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -625,8 +625,8 @@ if(WIN32)
else(WIN32)
set(DBUS_SESSION_BUS_LISTEN_ADDRESS "unix:tmpdir=${DBUS_SESSION_SOCKET_DIR}" CACHE STRING "session bus default listening address")
set(DBUS_SESSION_BUS_CONNECT_ADDRESS "autolaunch:" CACHE STRING "session bus fallback address for clients")
- set(DBUS_SYSTEM_CONFIG_FILE ${DBUS_DATADIR}/system.conf)
- set(DBUS_SESSION_CONFIG_FILE ${DBUS_DATADIR}/session.conf)
+ set(DBUS_SYSTEM_CONFIG_FILE ${DBUS_DATADIR}/dbus-1/system.conf)
+ set(DBUS_SESSION_CONFIG_FILE ${DBUS_DATADIR}/dbus-1/session.conf)
set(DBUS_USER "messagebus")
set(DBUS_TEST_USER "nobody")
# For best security, assume that all non-Windows platforms can do