summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorThomas Zimmermann <tdz@users.sourceforge.net>2016-08-12 10:50:53 +0200
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2016-08-15 14:30:51 +0100
commitbe04ba8354f8981ac33c66555464fdabc24d3a6a (patch)
tree501c4f20296520787cdac76b5dfb7e569ddeea74 /Makefile.am
parent1a30d452a48fa7c665906f0923adb49fc6ef016e (diff)
downloaddbus-be04ba8354f8981ac33c66555464fdabc24d3a6a.tar.gz
Use AX_CODE_COVERAGE for test-coverage statistics
DBus uses custom rules in its Makefiles to implement test-coverage statistics. This patch implements test-coverage statistics with the autoconf macro AX_CODE_COVERAGE. The script automatically tests for tools (e.g., gcov, lcov), sets build variables and creates Makefile rules. Run 'configure' with '--enable-code-coverage' to enable support for test-coverage statistics. Run 'make check-code-coverage' to run the tests and generate the statistics. Signed-off-by: Thomas Zimmermann <tdz@users.sourceforge.net> [smcv: do not alter compiler.m4; move AM_CXXFLAGS to the one place we compile C++] Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=88922
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 756ab8b9..db0d5228 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -33,4 +33,5 @@ DISTCHECK_CONFIGURE_FLAGS = \
ACLOCAL_AMFLAGS = -I m4 ${ACLOCAL_FLAGS}
-include tools/lcov.am
+# Add rules for code-coverage testing, as defined by AX_CODE_COVERAGE
+@CODE_COVERAGE_RULES@