summaryrefslogtreecommitdiff
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2018-08-29 20:06:00 +0100
committerSimon McVittie <smcv@collabora.com>2018-12-11 12:47:22 +0000
commit0c9f9432770596ec77a83f7a302c46108a651979 (patch)
tree2bee6d85809e5386abb7ae8656c98701a8ec04e6 /dbus/Makefile.am
parent64f94d3f5bc4e1229abc5a9ec7ae089b3b259719 (diff)
downloaddbus-0c9f9432770596ec77a83f7a302c46108a651979.tar.gz
build: Add a way to set CFLAGS for AddressSanitizer etc.
We don't want to set these globally via the normal CFLAGS, because if we did, AddressSanitizer would catch test-segfault deliberately segfaulting, and "helpfully" turn it into exit status 1, which in turn makes our test fail because it asserts that the segfault is reported as a segfault. A typical use with gcc as compiler, on a reasonably recent Debian, would be: ./configure SANITIZE_CFLAGS="-fsanitize=address -fsanitize=undefined -fPIE -pie" Signed-off-by: Simon McVittie <smcv@collabora.com>
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index c003b399..f9561bef 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -17,6 +17,7 @@ AM_CPPFLAGS = \
AM_CFLAGS = \
$(CODE_COVERAGE_CFLAGS) \
+ $(SANITIZE_CFLAGS) \
$(NULL)
if HAVE_VISIBILITY