summaryrefslogtreecommitdiff
path: root/dbus/Makefile.am
diff options
context:
space:
mode:
authorSimon McVittie <smcv@collabora.com>2017-06-20 13:08:06 +0100
committerSimon McVittie <smcv@collabora.com>2017-06-30 10:51:14 +0100
commit1477ca50354a313805690f6c9e581e9d26acefe0 (patch)
tree43c7f41282c63d1468892d6e230b75d8bb308a7d /dbus/Makefile.am
parent1cd79d185a4b1582f5fd71d2ff7f292b1202519e (diff)
downloaddbus-1477ca50354a313805690f6c9e581e9d26acefe0.tar.gz
build: Introduce ${runstatedir} and use it for the pid file
By default ${runstatedir} is the same as ${localstatedir}/run, but many Linux distributions configure it to be /run and mount a tmpfs in that location. All other factors being equal, it is preferable to use /run where available because it is guaranteed to be local, whereas traversing /var might involve automounting a networked filesystem (even though /var/run itself is very likely to be a tmpfs). /run or /var/run is currently only used in a few places in dbus, but I plan to make more use of it during the development of <https://bugs.freedesktop.org/show_bug.cgi?id=100344>. The pid file is not part of the API between dbus and other software (other than distribution init scripts for dbus itself), so we do not need to keep it strictly compatible; so it is OK to move it. We do not yet use /run for the system bus socket, because that is part of the API between D-Bus clients and servers, and has always been "officially" /var/run/dbus/system_bus_socket. <https://bugs.freedesktop.org/show_bug.cgi?id=101628> tracks the possibility of changing that. Similarly, we do not replace /var/run/console with /run/console, because that path is part of the API between dbus-daemon and the obsolete PAM modules pam_console and pam_foreground that used /var/run/console. <https://bugs.freedesktop.org/show_bug.cgi?id=101629> tracks the possible future removal of that code path. In the CMake build system, the equivalent of ${runstatedir} remains hard-coded to the equivalent of ${localstatedir}/run for simplicity. For the sort of system-wide installations that would consider redefining ${runstatedir} to /run, the Autotools build system is strongly recommended: in particular this is what Linux distributions are expected to use. Signed-off-by: Simon McVittie <smcv@collabora.com> Reviewed-by: Philip Withnall <withnall@endlessm.com> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=101569
Diffstat (limited to 'dbus/Makefile.am')
-rw-r--r--dbus/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/dbus/Makefile.am b/dbus/Makefile.am
index e4aa2eea..67ce8cce 100644
--- a/dbus/Makefile.am
+++ b/dbus/Makefile.am
@@ -12,6 +12,7 @@ AM_CPPFLAGS = \
-DDBUS_MACHINE_UUID_FILE=\""$(localstatedir)/lib/dbus/machine-id"\" \
-DDBUS_SYSTEM_CONFIG_FILE=\""$(dbusdatadir)/system.conf"\" \
-DDBUS_SESSION_CONFIG_FILE=\""$(dbusdatadir)/session.conf"\" \
+ -DDBUS_RUNSTATEDIR=\""$(runstatedir)"\" \
$(NULL)
AM_CFLAGS = \